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Configurations for Consultant CADD Managers 
1. Introduction 

Information in this document is based on software versions: MicroStation V8i (SELECT Series 2) 
version 08.11.07.443, Geopak V8i (SELECT Series 2) version 08.11.07.615, Office 2010 and 
ProjectWise Interplot Organizer V8i version 08.11.07.420 on the Windows 7 operating system. 

This document is intended as a guide for consultant CADD managers or IT personnel to use when 
setting up configurations for their personnel to apply T.D.O.T. Roadway Design Division standard 
files on their computer systems. 

Geopak’s Dependency on MicroStation 

The T.D.O.T. Roadway Design Division standard files for Geopak will not function correctly when 
downloaded by themselves. MicroStation standard files must be downloaded as well. Those files 
contain configurations, programs and other files called by various Geopak standard files. 
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2. Configuration Files 
The Roadway Design Division at T.D.O.T. uses configurations set at a default level. In other words 
they are always in place by default. Since consultants do project work for various customers this 
may not work for them. This section describes ways of dealing with this issue and maintaining 
functionality of the standard files in the software.  

Our configuration file for V8i is very comprehensive since all standards now reside outside the 
product folders. It utilizes variable names for the MicroStation and Geopak standards folders and 
only has 3 specific folder paths specified.  

MicroStation & Geopak - TDOT.cfg 
Default settings in TDOT.cfg: 
#------------------------------------------------------------------------------------------------------------------------------# 
# TDOT.cfg - TDOT Roadway Design Division Standards Configuration File for MicroStation V8i # 
#------------------------------------------------------------------------------------------------------------------------------# 
 
#==============================================# 
# This file sets MicroStation configurations              # 
# for TDOT Roadway Design Division's Use                # 
# Any changes made to this file may prevent access to          # 
# TDOT Roadway Design Division standards.                 # 
#==============================================# 
 
# ___________________________________________ MicroStation ______________________________________________ 
 
 
# TDOT Design Division MicroStation standards folder path 
_TDOT_MICROSTATION_STANDARDS = C:/Users/Public/MicroStation Standards/ 
 
# Special environment settings 
 
# When compressing DGN files, no options on by default 
MS_COMPRESS_OPTIONS  = -ALL 
 
# Include full path in Title Bar 
MS_FULLPATHINTITLEBAR  = 1 
 
# When updating levels do not delete unused levels 
MS_UPDATE_KEEP_UNUSED_LIBRARY_LEVELS = 1 
 
# Setting to allow attachment of large digital image files 
MS_RASTER_LOADMODE  = 3 
 
# Standard folders & files 
 
MS_SYMBRSRC  > $(_TDOT_MICROSTATION_STANDARDS)symb/*.rsc 
 
MS_SEEDFILES      < $(_TDOT_MICROSTATION_STANDARDS)seed/ 
MS_DESIGNMODELSEED  < $(_TDOT_MICROSTATION_STANDARDS)seed/seed2d.dgn 
MS_DESIGNSEED   = $(_TDOT_MICROSTATION_STANDARDS)seed/seed2d.dgn 
 
MS_CELL   < $(_TDOT_MICROSTATION_STANDARDS)cell/ 
MS_CELLLIST   < $(_TDOT_MICROSTATION_STANDARDS)cell/STDS.CEL 
MS_CELL_SEEDFILE   < $(_TDOT_MICROSTATION_STANDARDS)seed/English2dCell.dgn 
 
MS_PLTCFG_PATH  < $(_TDOT_MICROSTATION_STANDARDS)pltcfg/ 
MS_PENTABLE  = $(_TDOT_MICROSTATION_STANDARDS)pltcfg/ 
MS_PLOTDLG_DEF_PENTABLE = $(_TDOT_MICROSTATION_STANDARDS)pltcfg/TdotPlot.tbl 



 

 3 

MS_PENTABLE_DATE_FORMAT=%c 
 
MS_DATA   < $(_TDOT_MICROSTATION_STANDARDS)data/ 
MS_LEVEL_LIB_DIR  < $(_TDOT_MICROSTATION_STANDARDS)data/ 
MS_REMAP_CSVFILE   < $(_TDOT_MICROSTATION_STANDARDS)data/TDOTV8main.csv 
MS_V7TOV8_CSVNAME  = $(_TDOT_MICROSTATION_STANDARDS)dgnlib/TDOTV8mainOnTheFly.csv 
MS_V7_LEVEL_NAME_PREFIX = V7Level 
 
MS_VBASEARCHDIRECTORIES < $(_TDOT_MICROSTATION_STANDARDS)vba/ 
 
MS_TDOTDGNLIB_PATH  = $(_TDOT_MICROSTATION_STANDARDS)dgnlib/ 
 
%lock MS_DESIGNSEED 
 
# ___________________________________________ Geopak ______________________________________________ 
 
 
# TDOT Design Division Geopak standards folder path 
_TDOT_GEOPAK_STANDARDS = C:/Users/Public/Geopak Standards/ 
 
# Geopak resource file folder 
GPK_RSCDIR   = C:/Users/Public/Geopak Resource Files/ 
 
# Force all Geopak configuration variables to supersede RSC file settings 
GPK_FORCE_ALLCFGVARS  = 1 
 
# Setting to create level if not found 
GPK_LEVEL_CREATE_NEW = 0 
 
# Setting to allow Geopak attributes to show with Accusnap 
GPK_ACCUSNAP_IDENTIFY_ELEMENTS_AUTOMATICALLY = 1 
 
# Setting to control station ticks on alignments displayed from D&C Manager 
GPK_DDB_STA_SMALL_TICKS = 0  # ticks left label left 
GPK_DDB_STA_LARGE_TICKS = 2  # ticks both label left 
 
# Suppress warning for shapeless in proposed typical sections 
GPK_TYPICAL_SUPPRESS_SHAPELESS_MODE_VALIDATION_PROMPT = 1 
 
# Suppress warning for criteria file overwrite in proposed typical sections 
GPK_TYPICAL_SUPPRESS_CRITERIA_FILE_OVERWRITE_PROMPT = 1 
 
# Standard folders & files 
 
# Geopak Databases: D&C Manager DDB, Drainage Library, COGO SMD 
GPK_ACBOOK_DDBFILE  < $(_TDOT_GEOPAK_STANDARDS)tdot.ddb 
GPK_DRGPREF_DEFDRLIB  < $(_TDOT_GEOPAK_STANDARDS)TDOTEnglish.dlb 
GPK_SURVMNGR_SMDFILE  < $(_TDOT_GEOPAK_STANDARDS)TNDOT.smd 
 
# COGO Visualization preferences 
GPK_VISUALPREF_SMD  < $(_TDOT_GEOPAK_STANDARDS)TNDOT.smd 
GPK_VISUALPREF_PLOTSCALE = 50.00000 
 
# Superelevation design control files 
GPK_SUPER_PREFDIR  < $(_TDOT_GEOPAK_STANDARDS) 
GPK_SUPER_EDIR   < $(_TDOT_GEOPAK_STANDARDS) 
GPK_SUPER_LENGTHDIR  < $(_TDOT_GEOPAK_STANDARDS) 
 
# Design control file for vertical curves 
GPK_PROFILE_CURVATURE_TABLE  = $(_TDOT_GEOPAK_STANDARDS)tdot01.kvl 
 
# 3PC programs location 
GPK_DC_3PCDIR   < $(_TDOT_GEOPAK_STANDARDS)3PC/ 
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# XS criteria programs location, typical section controls 
GPK_MY_CRITERIADIR    < $(_TDOT_GEOPAK_STANDARDS)criteria/ 
GPK_TYPICAL     < $(_TDOT_GEOPAK_STANDARDS)criteria/ 
GPK_TYPICAL_EDITOR    < C:\WINDOWS\system32\write.exe 
 
# Plan & Profile sheet set up library and folder location 
GPK_SHEETCLP_SHEET_LIBRARY_NAME   = $(_TDOT_GEOPAK_STANDARDS)tdot.psl 
GPK_SHEETCLP_SHEET_LIBRARY_DIR    = $(_TDOT_GEOPAK_STANDARDS) 
 
# Geopak Corridor Modeling Databases for Roadway Designer: Template Library and Styles DDB 
GPK_RD_Template_Library  < $(_TDOT_GEOPAK_STANDARDS)TDOTDefault.itl 
GPK_ACBOOK_DDBFILE_STYLES  < $(_TDOT_GEOPAK_STANDARDS)TDOT_Styles.ddb 
 
# default drainage cell library used by Geopak 
GPK_DRGPREF_DEFCELLLIB  < $(_TDOT_MICROSTATION_STANDARDS)cell/STDS.CEL 
 
# Label Style Files 
GPK_LABELER_PLANSTYLEFILE   = $(_TDOT_GEOPAK_STANDARDS)tdotdef_plan.lsf 
GPK_LABELER_XSSTYLEFILE     = $(_TDOT_GEOPAK_STANDARDS)tdotdef_xs.lsf 
GPK_LABELER_PROFSTYLEFILE   = $(_TDOT_GEOPAK_STANDARDS)tdotdef_prof.lsf 
GPK_LABELER_DRGSTYLEFILE    = $(_TDOT_GEOPAK_STANDARDS)tdotdef_drainage.lsf 

 Setting up TDOT.cfg as a project level configuration 
Go to MicroStation Manager and in the Project field at the bottom pick New. In the Create New 
Project dialog enter the desired project name and description. Click OK to set up the project. 

. 

When a project is created, a project level configuration file is generated using the project name 
with a pcf extension. In our example this file would be named TDIOT.pcf and found at  
C:\ProgramData\Bentley\MicroStation V8i (SELECTseries)\WorkSpace\Projects 

Default settings in TDOT.pcf. 
#====================================================================== 
# Project Configuration File - $Revision: 1.2 $   
#====================================================================== 
 
_USTN_PROJECTDESCR = TDOT Roadway Design Division Project 
 
#---------------------------------------------------------------------- 
#  Set search paths. 
#---------------------------------------------------------------------- 
MS_DEF   < $(_USTN_PROJECTDATA)dgn/ 
MS_CELL   < $(_USTN_PROJECTDATA)cell/ 
MS_CELLOUT  = $(_USTN_PROJECTDATA)cell/ 
MS_CELLLIST  < $(_USTN_PROJECTDATA)cell/*.cel 
MS_CELLSELECTORDIR   = $(_USTN_PROJECTDATA)cell/ 
MS_SEEDFILES      > $(_USTN_PROJECTDATA)seed/ 
MS_SYMBRSRC  > $(_USTN_PROJECTDATA)symb/*.rsc 
MS_SETTINGSDIR        < $(_USTN_PROJECTDATA)data/ 
MS_SETTINGSOUTDIR    = $(_USTN_PROJECTDATA)data/ 
MS_DGNLIBLIST      < $(_USTN_PROJECTDATA)DGNLIB/*.dgnlib 
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%lock MS_DESIGNMODELSEED 
%lock MS_SHEETMODELSEED 
%lock MS_DRAWINGMODELSEED 
%lock MS_DWGMODELSEED 
%lock MS_DESIGNSEED 

Open TDOT.cfg, copy its contents and paste them in the project configuration file at the end. 

Eliminate duplicate settings from the default project configuration file definitions. 
MS_CELL   < $(_USTN_PROJECTDATA)cell/ 
MS_CELLLIST  < $(_USTN_PROJECTDATA)cell/*.cel 
MS_SEEDFILES      > $(_USTN_PROJECTDATA)seed/ 
MS_SYMBRSRC  > $(_USTN_PROJECTDATA)symb/*.rsc 
%lock MS_DESIGNSEED 

Delete any you may not need.. MS_DEF is only needed if all MicroStation DGN files are to be 
kept in a single location. T.D.O.T. Roadway Design Division doesn’t use MicroStation settings 
files or multiple DGNLIB files together. The %lock function locks the current definition and 
should always be placed at the end of the file but no models other than the default model are used. 
MS_DEF   < $(_USTN_PROJECTDATA)dgn/ 
MS_CELLOUT  = $(_USTN_PROJECTDATA)cell/ 
MS_CELLSELECTORDIR   = $(_USTN_PROJECTDATA)cell/ 
MS_SETTINGSDIR       < $(_USTN_PROJECTDATA)data/ 
MS_SETTINGSOUTDIR    = $(_USTN_PROJECTDATA)data/ 
MS_DGNLIBLIST      < $(_USTN_PROJECTDATA)DGNLIB/ 
 
%lock MS_DESIGNMODELSEED 
%lock MS_SHEETMODELSEED 
%lock MS_DRAWINGMODELSEED 
%lock MS_DWGMODELSEED 

Add additional configurations as needed. Our configuration file is comprehensive and probably 
will not need any additional configuration variables.  

Reset all paths as needed for your system.  Our configuration file only includes the following 3 
path settings which would need to be adjusted for use on your system. 
_TDOT_MICROSTATION_STANDARDS = C:/Users/Public/MicroStation Standards/ 
_TDOT_GEOPAK_STANDARDS = C:/Users/Public/Geopak Standards/ 
GPK_RSCDIR   = C:/Users/Public/Geopak Resource Files/ 

The configuration variable GPK_RSCDIR is new with V8i and reflects the location on the local 
hard drive where Geopak RSC files are placed. In the past these went in the Geopak\bin folder 
where the software resides. These files do get corrupted sometimes and it was always  a little 
dangerous to have users delete them from that location. In addition to that situation and depending 
on your system set up, Windows 7 can be lot more restrictive on users placing data within the 
product folders. It needs to be a location that the user has access to and can write files to. 

Use the basic guidelines described in the following section to finalize the configuration definitions 
in the project configuration file. Copy this file to the Projects folder for application at other PC 
locations.  
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Basic Editing of Configuration Files (from MicroStation Help) 

Configuration variable files are text files that consist of a series of lines. Each line contains a 
configuration variable name and definition in the following syntax: 

<VARIABLENAME> <operator> <new_value> # comment 

VARIABLENAME is the name of the configuration variable defined. Nearly all variable names 
used by MicroStation begin with “MS_” or “_USTN_.” Variables whose names begin with an 
underbar ( _ ) are not displayed in the Configuration dialog box. 

Available values for operator are as follows: 

Operator Meaning 
= Assign new_value to VARIABLENAME. Overrides all previous definitions at or 

below the current configuration variable level. 

: Assign new_value to VARIABLENAME only if that variable does not already exist. 

+ Append new_value to current value of VARIABLENAME. Uses a space as a 
separator. 

>  Append directory or file lists defined by new_value to a variable definition that defines 
a path. If no current value for VARIABLENAME exists, this is equivalent to the = 
operator. Otherwise, it appends a path separator character, a semicolon (;), and then 
new_value. 

<  “Prepend” directory or file lists defined by new_value (to the beginning of) a variable 
definition that defines a path. If no current value for VARIABLENAME exists, this is 
equivalent to the = operator. Otherwise, it prepends new_value followed by a path 
separator character, a semicolon (;). 

#  Anything after a # on a line is treated as a comment and is ignored. 

File path names should be entered using the forward slash (/). Windows converts all forward 
slashes (/) in new_value to backslashes (\). Also, all directory definitions should end with a trailing 
forward slash. 

This is an example of a valid directory definition: 
MS_DEF = /network/dgn/ 

When editing a configuration variable file, insert a carriage return at the end of the last line to 
ensure the entire file will be processed. Press <Enter> to insert a carriage return. 
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Interplot - Iplot.cfg, Iplotsrv.cfg & ip.cfg 

These are software product level configuration files that have been customized for use by T.D.O.T. 
Roadway Design Division personnel. They are rather large files, so listed below each filename are 
configurations of particular interest that may need to be reset for your system. 

Default Folder Location: C:\Program Files (x86)\Common Files\InterPlot\IPLOT\config 

Iplot.cfg 
IPLOT_OUTPUT_DIR = c:\temp 
IPLOT_DLOG_OUTPUT_DIR = c:\temp 
IPLOT_DLOG_SAVE_DIR = c:\temp 
 
IPLOT_COLOR_TABLE_PATH = "C:\Users\Public\MicroStation Standards\data" 
IPLOT_PEN_TABLE_PATH = "C:\Users\Public\InterPlot Standards\Design Scripts" 

Iplotsrv.cfg 
IPLOTSRV_PATTERN_PATH = "C:\Users\Public\InterPlot Standards\resrc" 
 
IPLOTSRV_LINESTYLE_PATH = "C:\Users\Public\InterPlot Standards\resrc" 

Default Folder Location: C:\Program Files (x86)\ProjectWise InterPlot Organizer\config 

ip.cfg 
IP_SETTINGS_PATH = "C:\Users\Public\InterPlot Standards\Settings" 
 
IP_DEFAULT_SETTINGS = iplot.set 
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3. Hard Coded File Paths 
Although hard coded file paths e avoided wherever possible some standard files will not function 
correctly without being set this way. The following section lists the various standard files grouped 
by software type that have hard coded file paths.   

MicroStation & InterPlot 
Default Folder Location: C:\Users\Public\MicroStation Standards\vba 
IplotSet.mvba  (sett default Iplot settings file)  

This only a concern if you use InterPlot software. 

Access the Set Iplot Default Settings tool through the TDOT drop down menu option Iplot – 
Default Settings or through Geopak’s D&C Manager at Drafting Standards > Tools> Set Iplot. 

 
Open the Visual Basic Editor at Utilities > Macro> Visual Basic Editor 

To edit: 
Navigate to module & subroutine or use the Replace function to find locations 
Make changes as needed 
Click Save icon in Visual Basic Editor 

from form code SelectFiles 
subroutine IplotSettings_Click 
settingsFile = "C:\Users\Public\InterPlot Standards\Settings\" + fileName 

settingsFile = "C:\Users\Public\InterPlot Standards\Settings\" + fileName 

testString = Dir("C:\Users\Public\InterPlot Standards\Settings\iplot.set") 

Kill "C:\Users\Public\InterPlot Standards\Settings\iplot.set" 

FileCopy settingsFile, "C:\Users\Public\InterPlot Standards\Settings\iplot.set" 

from module Start 
subroutine Main 
If FileLen("C:\Program Files (x86)\Common Files\InterPlot\IPLOT\bin\iplot.exe") > 0 Then 

fpath = "C:\Users\Public\InterPlot Standards\Settings" 
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Geopak 
Default Folder Location: C:\Users\Public\Geopak Standards 
DrainageProject.gdf  (default drainage project)  

TDOTdrainageprefs.dpf  (default drainage project preferences)  

Preferences: criteria directory, DDB 

 
Note::  
The Drainage Library and Drainage Cell Library are now set by configuration variables. 

To edit both files: 
Start Geopak Drainage 
Go to Drainage>Project>Open 
Navigate to Geopak  Standards folder and open DrainageProject.gdf 
Go to Drainage>Project>Preferences 
Under Project Components make path changes as needed 
Go to File > Save As 
Navigate to Geopak  Standards folder, select file name TDOTdrainageprefs.dpf and click Save 
Click OK to close Preferences dialog 
Go to Drainage>Project>Save 
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Office (Excel) 
Open the template file and then the Visual Basic Editor at View > Macros> View Macros> Edit 
Note: Due to the many instances of the same folder path in some templates you should use the 
Replace function under Edit>Replace in the Visual Basic Editor as shown below. 

 .  

To edit: 
Navigate to module & subroutine or use the Replace function to find locations 
Make changes as needed 
Click Save icon in Visual Basic Editor 

Default Folder Location: C:\Users\Public\Office Standards\TDOT 2nd Sheets 

Convert Excel To V8.xltm                (Estimated Roadway Quantities.xltm file path, menu control) 
from module ConvertEstimatetoV8 
subroutine ConvertEstToV8 
Workbooks.Add Template:= _ 
“C:\Users\Public\Office Standards\TDOT 2nd Sheets\Estimated Roadway Quantities.xltm" 

MsgBox "File " + Chr(34) + _ 
"C:\Users\Public\Office Standards\TDOT 2nd Sheets\Estimated Roadway Quantities.xltm" + _ 

from module ConvertMenu 
subroutine CreateConvertMenu 
 .OnAction = "C:\Users\Public\Office Standards\TDOT 2nd Sheets\Convert Excel To V8.xltm!ProcessSelection" 

Estimated Roadway Quantities.xltm,  (Items.dat file path, auto build calls in Roadway only) 
Bridge Quantities.xltm,  
Maintenance Quantities.xltm 
from form code SearchForText 
subroutine UserForm_Initialize 
 Open "C:\Users\Public\Office Standards\TDOT 2nd Sheets\Items.dat" For Input Shared As #1 
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from module AutoBuildCalls 
subroutine BuildGRBlock 
Workbooks.Open "C:\Users\Public\Office Standards\TDOT English Tab Quantities\Guardrail Tab Builder.xltm", , 
True 

subroutine runcheckitemsGR 
Workbooks.Open "C:\Users\Public\Office Standards\TDOT English Tab Quantities\Guardrail Tab Builder.xltm", , 
True 

subroutine BuildStormDrainagePipes 
Workbooks.Open "C:\Users\Public\Office Standards\TDOT English Tab Quantities\Storm Drainage Pipe Tab 
Builder.xltm", , True 

subroutine runcheckitemsSS 
Workbooks.Open "C:\Users\Public\Office Standards\TDOT English Tab Quantities\Storm Drainage Pipe Tab 
Builder.xltm", , True 

subroutine BuildCatchBasinsBlock 
Workbooks.Open "C:\Users\Public\Office Standards\TDOT English Tab Quantities\Storm Drainage Structure Tab 
Builder.xltm", , True 

subroutine runcheckitemsCB 
Workbooks.Open "C:\Users\Public\Office Standards\TDOT English Tab Quantities\Storm Drainage Structure Tab 
Builder.xltm", , True 

from module datfilchecks 
subroutine CheckforDat 
Open "C:\Users\Public\Office Standards\tdot 2nd Sheets\Items.dat" For Input Shared As #1 

datdate = FileDateTime("C:\Users\Public\Office Standards\TDOT 2nd Sheets\Items.dat") 

subroutine checkforTxt 
Open "C:\Users\Public\Office Standards\tdot 2nd Sheets\items.dat.txt" For Input Shared As #1 

txtdate = FileDateTime("C:\Users\Public\Office Standards\tdot 2nd Sheets\items.dat.txt") 

subroutine dattxt 
FileCopy "C:\Users\Public\Office Standards\tdot 2nd Sheets\items.dat.txt", "C:\Users\Public\Office Standards\tdot 2nd 
Sheets\Items.dat" 
Kill "C:\Users\Public\Office Standards\tdot 2nd Sheets\items.dat.txt" 

Kill "C:\Users\Public\Office Standards\tdot 2nd Sheets\items.dat.txt" 

subroutine DateCheck 
datdate = FileDateTime("C:\Program Files\Microsoft Office\Templates\tdot 2nd Sheets\Items.dat") 

subroutine netDownload 
msg2 = "C:\Users\Public\Office Standards\tdot 2nd Sheets" 

subroutine TxtCopy 
FileCopy "C:\Users\Public\Office Standards\tdot 2nd Sheets\items.dat.txt", "C:\Users\Public\Office Standards\tdot 2nd 
Sheets\Items.dat" 
Kill "C:\Users\Public\Office Standards\tdot 2nd Sheets\items.dat.txt" 
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from module FillIn_Items 
subroutine FillinItemNos 
Open "C:\Users\Public\Office Standards\tdot 2nd Sheets\Items.dat" For Input Shared As #1 

Default Folder Location: C:\Users\Public\Office Standards\TDOT English Tab Quantities 

Guardrail Tab Builder.xltm,    (Items.dat file path) 
from module ItemNumbersCheck 
subroutine checkitemsGR 
ItemsPath = "C:\Users\Public\Office Standards\tdot 2nd Sheets\" 

Storm Drainage Pipe Tab Builder.xltm,   (Items.dat file path) 
from module CheckItemsDat 
subroutine checkitemsSS 
ItemsPath = "C:\Users\Public\Office Standards\tdot 2nd Sheets\" 

Storm Drainage Structure Tab Builder.xltm,   (Items.dat file path) 
from module ItemNumbersCheck 
subroutine checkitemsCB 
ItemsPath = "C:\Users\Public\Office Standards\tdot 2nd Sheets\" 

Default Folder Location: C:\Users\Public\Office Standards\Survey 

Survey_Contact_Acq_Create.xltm  (ROWAcqTable.xltm, help & letter template file paths) 
from Microsoft Excel Objects code Sheet1 (Project Info) 
subroutine cmdAcqTable_Click 
strPath = "C:\Users\Public\Office Standards\Survey\" + "ROWAcqTable.xltm" 

subroutine cmdHelp_Click 
 FName = "C:\Users\Public\Office Standards\Survey\Survey Contact Letter and R.O.W. Acquisition Table 
Creator.pdf" 

from form code Letter 
subroutine cmdCreateLetter_Click 
 strLetterPath = "C:\Users\Public\Office Standards\Survey\" 
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